As an Amazon Associate I earn from qualifying purchases from amazon.com

There are compatibility issues with Exascend CFexpress cards and EOS R5 firmware v1.4.0 | Canon Rumors


This site contains affiliate links to products and services. We may receive a commission for purchases made through these links.

It came to my attention today that there appear to be compatibility issues with the latest Canon EOS R5 firmware and Exascend CFexpress memory cards.

Shooters with a Canon EOS R5 and firmware v1.4.0 are getting camera lockups when attempting to format the memory card in the Canon EOS R5.

Images courtesy of Highigan via Discord

From Exascend

Some Canon EOS R5 users have reported problems using their Exascend Essential CFexpress after updating their camera system to firmware version 1.4.0.

If you are experiencing similar problems, please contact the store or online retailer where you bought the product to proceed with a firmware upgrade of your Exascend Essential CFexpress card that ensures continued compatibility with the Canon EOS R5 system.

The solution offered by Exascend doesn’t appear all that helpful, I’m not sure how Amazon is going to help owners with a firmware update for the memory card.

I have reached out to Exascend for further clarification



We will be happy to hear your thoughts

Leave a reply

Logo
Enable registration in settings - general
Compare items
  • Total (0)
Compare
0